[Solved] Roku App Issue: Kicking back to home

The problem started today. I could access the app fine, but the episode lists were not showing and I pressing “Watch now” would result in an error message saying the video was unavailable. Then, after resetting the internet and redownloading the app multiple times, the app began crashing immediately after opening the home page. I’ve been unable to access it since. I’ve seen forum posts of a similar problem back in April, so I’m assuming something similar is happening now. Is anyone else having this issues?



  • Official comment

    Hi Everyone,

    Thank you for reaching out to Viki Community Support!

    We apologize for experiencing an issue with Viki on Roku. Our engineers have gotten back to us and the issue has been fixed. Please try to log out and log back in before trying again.

    If you continue to experience this issue after, please send details (screenshots included) to our Help Center at and we will get back to you as soon as possible.


    Comment actions Permalink
  • Same problem here. I tried the fix from last April, it took me several attempts, clicked the left arrow button as soon as the site was up, then scrolled down to "explore" and found my current show there. I tried the "watchlist" menu first but I also got kicked our from there.

    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post