Can't download app on Google play

Does anyone else have problems downloading the app on Google play? Is there a way to fix this? I have tried what was mentioned in other posts, but it won't even allow me to attempt installing the app. Whenever i press on install a message saying log into Google account pops up (i am logged in). I tried installing other apps they work fine.


1 comment
  • Official comment

    Hi olgasalinas03_886,

    Thanks for getting in touch with us.

    Due to app compatibility issues, we are unfortunately unable to support issues on older devices that don’t have the current device requirements needed for the app (Android 6.0 or higher and/or iOS 12.0).

    There are also 2 other possible reasons why you might not be able to install the app on your device:

    1. Your device is currently not certified by Google. For more information on whether your device is certified, please visit:
    2. Your device is rooted and/or does not support DRM playback. You can check if your device supports DRM playback by downloading this app. Please screenshot the results and send them to us when replying to this email.

    If your device meets these requirements and you’re still experiencing issues, please let us know, and we’d be glad to look into it for you.



    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post