[Closed] Viki app won’t work on my Roku streaming player

I just added the Viking channel onto my Roku 2 HD, which is up to date (software 9.1.0), and when I load the app, it keeps telling me I need to update the app. I went back and checked for updates, the app then updates. But when I open Viki, it brings me the same screen, saying I need to update the app. I have tried uninstalling it and reinstalling it, and I have tried restarting my Roku. Nothing seems to work. I’d imagine that if this device wasn’t supported, the app wouldn’t even show up in Roku’s channel shop. I’m seeing a lot of people posting similar issues; I really want to be able to use this service somewhere other than my phone. Is there a solution to this? Viki is on so few devices as it is.



1 comment
  • Official comment

    Hi there victorianromantic_245,

    Thanks for reaching out. 

    We've seen that your ticket on the Help Center has been attended to and we’ll be closing this to prevent confusion of multiple requests.

    Should you have any further questions, please feel free to contact us anytime.

    Have a great day! 


    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post