[Solved] "oh no! Something went wrong" - Fire TV stick

 I was in the middle of watching an episode of Flower of Evil when this message popped up. I have had it once before, but after restarting my Fire Tv stick it cleared it. But this time it won't go away no matter what I try.

 I am on the new FireStick 4k Max stick, with the latest updates. I have deleted and reinstalled the app. I have rebooted my home network, but nothing is working? I can still watch on my laptop (but that isn't suitable really) and so it must be some silly niggly issue?

 Can anyone help at all? I have seen previous posts here and followed all the advice to no avail. Thanks



  • Official comment

    Hi all,

    This Fire TV issue is now fixed so you may return to watching Viki on your device. 

    If the same issue persists, remember to delete and reinstall your app first before trying again. 

    For further assistance on this, please send details (screenshots included) to our Help Center at and we will get back to you as soon as possible.

    Thank you,

    Comment actions Permalink
  • The same message for me and i also watch on fire tv ! 

    Comment actions Permalink
  • Same is happening to me too, tried rejoining and reinstalling viki app on firetv 4k, clearing cache etc..., tried deregistering on firetv too but nothing is working... both are newest versions, firetv is software version (NS6281/4061) and viki app is 2.19.0

    Comment actions Permalink
  • Hi everyone,

    Thank you for writing to Viki Community Support!

    We're sorry that you're experiencing issues with Viki on your Fire TV Device. As much as possible, we want you to have an uninterrupted viewing experience.

    To make sure this is not an app problem can you please try the following?

    1. Log out from your account
    2. Uninstall and reinstall the Viki app from your device.
    3. Turn your device off and on again.
    4. Log back in to your Viki account by following the steps here.

    Are you still having the same issues with the Viki app? If so, can you please provide the following information?

    1. Your Fire TV device OS (You can see your version of Fire OS by going to Settings > Device > Fire TV and looking at the "Software Version" details)
    2. Your Viki app version (On the app, Left Side Bar > Settings > About Viki)
    3. Which specific movies or episodes are causing this issue? Please give as many details as possible
    4. What do you see when loading the video? A screenshot/picture of the error message or issue would be helpful.

    We look forward to your response.


    Note: To respond to this thread, please click on "View the post" in the email notification. Responses to the email notification will not update the thread and are not received.

    Comment actions Permalink
  • Viki app version: 2.19.0

    Fire TV OS version: (PS7255/2444)

    Happening with ever single episode of any show I try. Search also doesn't function at all and just stays on a blank screen.

     I should note that the same problem is also happening on the browser on my Xbox Series X. It uses Microsoft Edge (same as my laptop) and the same error message appears. Only an actual Windows machine will play anything.

    This is what the screen shows:

    Comment actions Permalink
  • Hello there,
    Thank you for getting back to us!
    We're sorry that you're experiencing this issue. Our team is aware of it and will be looking into it as soon as they can.
    We've forwarded all the information you provided to our engineering team and we expect to have a resolution for this problem when possible.
    Hope this helps for now. Please do let us know if you have any additional questions or concerns.
    Thank you,
    Comment actions Permalink
  • Olá, boa tarde.

    Também estou tendo o mesmo problema com meu Fire TV.
    Já reiniciei, desinstalei d nada.

    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post