[Closed] Not saving my progress on a new show

I started watching a new show this week and noticed it is not being saved in my “continue watching” list. This is happening for both phone and Roku. I have tried the logging out, uninstalling, logging in that previous posts have suggested.


  • Official comment

    Hi all,

    We're aware of the Continue Watching issue, and our team is working on it. The issue should be resolved in a day or so. 

    Do follow this post for any updates as this duplicate topic would be closed.

    We appreciate your patience and understanding in this matter.


    Comment actions Permalink
  • Same as mine.

    Comment actions Permalink
  • Hi kzb92fzqk9_854 and walshf59_954,

    Thanks for writing in. 

    We're truly sorry for what you've experienced. If you have tried the basic troubleshooting steps suggested, can you please provide the following information?

    1. Which device and model number are you using?
    2. Your current location /region.
    3. Which specific movies or episodes are causing this issue? Please give as many details as possible
    4. A screenshot, picture, or short video of the error message or issue if there's any. 

    We appreciate your patience and understanding. Should you have any further questions, please feel free to contact us at any time via HELP CENTER




    Comment actions Permalink
  • My phone is an iPhone SE, tv is ROKU TCL series 4.
    My region is USA. 
    The show is Princess Silver - all episodes.
    There aren’t any error messages.

    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post