[Solved] Viki app on Google TV

I got a new Chromecast with Google TV and the Viki app is loading like it’s a mobile app instead of the TV app that I watched on my other Chromecast with Google TV. I’ve uninstalled and reinstalled and it’s still coming up like the mobile app. Also doesn’t show an option to Open the app, only “Free Trial” and “uninstall”. I already have a Plus subscription so I don’t want to click the Free Trial option.


  • Official comment

    Hi all,

    Apologies for the confusion with your Android TV app!

    This issue is now rectified. Please delete the current app on your Android TV/Google TV and reinstall the updated app version 2.18.2

    If you are still having technical issues, please send details (screenshots included) to our Help Center at and we will get back to you as soon as possible.


    Comment actions Permalink
  • Hello ashleyrod82_923,

    Thanks for writing in!

    I’m sorry that you're experiencing issues with Viki on your Google TV Device.

    Since you're still having the same issues with the Viki app after reinstalling it, may you please provide the following information?

    1. What is version of the Viki app are you using? You can find this information in the app settings.
    2. An exact description of the issue you're experiencing.
    3. Which Google TV  model number are you using?
    4. A screenshot, picture, or of the error message or issue.

    I'll look forward to your response.




    Note: To respond to this thread, please click on "View the post" in the email notification. Responses to the email notification will not update the thread and are not received.

    Comment actions Permalink
  • I am having the same problem I have submit my own ticket to the help center today at 12:25 I am caquila01_459. Could you please tell me if there is a solution, I thought it was the TV but my first Chromecast with Google TV I tried it first in this AOC TV and also used it on an LG TV that was not smart and it function well. 

    But now that I bought a new Chromecast device I cannot open the app in no one of these Tv I tried my first Chromecast and it only can be use as a simple cast device and when I go to the app lists its like the app in the mobile. 

    The version in the mobile is 6.17.0 the version that can be install from Play Store in the TV is the same.

    The model of the Chrome Cast with Google TV is GZRNL 

    Comment actions Permalink
  • I'm having the same issue, actually, mine's with my Android TV (nvidia).

    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post