Annual Pass / Pass Discount / Renewal + poor page load times

Good Day,

I emailed in October and received no response; and I just followed up just a few days ago and of course I received absolutely no response as of yet.  I'm not sure if my inquiry is being ignored or you guys do not have a big enough work force and are incredibly backed up; so I will post here as it seems the likelyhood of getting a reply is much faster here.

My question was in regards to my automatic renewal date and the policy concerning the pricing.  It states that after the discounted price you will be automatically renewed for the regular price. I came from Dramafever before it shut down and the annual renewal followed the price during the discounted promotion price every year.  What I am getting too is why isn't there a system like that here?  Especially when right now there is a 30% promotion yet again for an annual renew (I have seen up to 40% discount too?) on your page and promotions seem to pop up quarterly, but I got renewed for the full price.  Is there a way to get a discount? (wish I got a reply before I had to renew) or do I have to cancel, get a refund then resign up? and what would happen if I wanted to upgrade to plus? I would pay for the difference per month minus the months already past?

 

The later question is in regards to the new format of your site. The load time quality is so poor when accessing pages other than the main site splash page. eg browse/search. When you refine search it pretty much takes a double click reload and extended wait to change search parameters. And when accessing individual show pages they take a long time to load; and sometimes the episodes show up as having none (basically don't load up). I take issue with this as I am annoyed to actually seeing a loading circle when trying to refine search; then it blinks back to the same unchanged parameters then I have to click again and still wait for it to load again. Either your page is poorly optimized or your server capacity has diminished with more users.  I also see on the bottom left corner of the page waiting for viki.com ~ means its loading way too slowly. This isn't my computer or my connection as I know I will get that automatically filled in as a reply.  Your site had no issues prior till you forced the new setup on us.

On top of that when first playing a video I noticed that the top login search loads up as you logged out then refreshes as logged in before slowly loading the video up. And as of late there are intermittent crashes on videos and at the end of the episodes during continuous play hiccups and double reloads and jumps another chapter completely.  eg from 12 then to 14. 

Also it logs me out of the site after a day or two if I don't visit the site? when it never happened before asks me to log in again. The video settings for fonts/size keep resetting if you watch different shows.

The overall service quality seems like it has dropped compared to the old site setup. Honestly it seems like an optimization issue when trying to port the site to the new design coding framework. Of which I expect you to deny and run me through troubleshooting of which later you probably are slowly trying to fix.  Honestly I'm not sure why you had to upgrade the look of the site; when people beta a new build they always mess up something and takes forever to fix all the 'minor' issues.

 

To whoever is reading or will reply this is not a slight toward you; its the frustrating in having to deal with customer service for issues that should be non issues.

Thank You kindly in advance ~

0

Comments

0 comments

Please sign in to leave a comment.

Didn't find what you were looking for?

New post