Answered

[Solved] App no longer compatible with my Galaxy S10?

The app has been working great until 2 weeks ago. I uninstalled it at the time because the app wasn't working correctly. Now I can't even install it again because of a warning stating that my device is not compatible with the app. My phone isn't jail broken or unlocked. Please help.
1

Comments

1 comment
  • Hi there,

    Thanks for writing in to us.

    I'm sorry to hear that your device is not compatible with the Viki app. 

    After a detailed investigation, our engineers have concluded that the Viki app is unable to work correctly on certain Samsung models after the latest security update from Samsung was made certain devices. For more information, please see this article

    We are sorry for this inconvenience, and we seek your understanding on this matter. In the meantime, we would like to recommend you to watch from another device.

    All the best,
    Michelle‍

    0
    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post