No Subtitles on Roku and MiBOX3

Since May 18th 2019 I noticed that no matter which language I choose, no subtitles are showed when watching on Roku Express and MiBox3 (Android TV) app.

On my iPhone app and Web access the subtitles are fine.

On MiBox3 I`ve tried to clear all cache, uninstall and reinstall the app but nothing worked.

Also, sometimes the app takes a little longer to connect, sometimes it asks for a retry and sometimes after trying to connect for a long time, it asks me to login again. 

Anyone with the same problem??

What should I do?

I reported this problem on the iPhone app but 2 days passed but nobody replied.




1 comment
  • Today I noticed that MiBox is ok. Subtitles are ok, no need to reinstall or clean any cache. Probably a server problem.

    Updated Roku's beta app to the final version. Subtitles are showing ok but just for the 4 languages available on Roku's System language menu (English, Spanish, French and German).

    On the beta version the subtitles language was associated to the captions language menu, so all languages were available. This should be a quick fix. Let's wait and see.

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post