[Solved] Issue: No Subtitles on Roku

We're aware of the issues affecting subtitles on the Roku Viki app. Our team is investigating. Sorry for the inconvenience

 
-3

Comments

58 comments
  • Bob118's method fixed this issue for me! Thank yooou!

    3
    Comment actions Permalink
  • That's great bob118... but it'll be inconvenient having to for that for each episode which I had to do last night, when it should Judy pop

    1
    Comment actions Permalink
  • Just pop up automatically

    0
    Comment actions Permalink
  • it will soon be 24 hours since all subtitles on all videos disappeared on Viki through Roku for me.  i have tried all suggestions, sign out and back in, uninstalling and reinstalling app, even the suggestion that bob118 provided which worked for him for 5 episodes. the CC button is highlighted but subtitles did not appear. Please please Viki engineers HELP!!!!! We need subtitle issues fixed so our subscription will once again bring back smiles!!! Right now there are many of us who are frustrated and sad :( :( :(

    4
    Comment actions Permalink
  • Subscribers are valiantly being the good guys and assuming there is something they can try or do concerning the missing subtitles and VIKI's absolute crash and burn since late last night.  It is not our apps or TVs: it is VIKI and ROKU--and neither of them are doing anything to ease our concerns except they are "aware." But that is not good enough: this is actually a legal issue because they have taken our money. The owner-manager must address this, tell us exactly what is wrong, what they are doing to fix it, and how long it will be.

    NOW.

    0
    Comment actions Permalink
  • dizzybugs

    Back out of the show you are watching. Load the show. Go to accessibility and change your language to a new one and then wait for 5 seconds. Sometimes it takes a few moments for it to work. Then switch back to the language you want. 

    Also you can try freshly loading the program, forwarding a bit, then go back a bit and hit play. Then go to accessibility and switch to a new language. This is what is suggested on the Kocowa app which is having the same exact issues. (Which makes me wonder if it is related to Kocowa). 

    https://help.kocowa.com/hc/en-us/articles/360018785133-Missing-Subtitles-on-Roku 

    Also, if you leave the program on pause for too long sometimes you have to do this over again. It has worked for every show for me but a few times I had to do it a few times before it worked. NO idea what it's all about. 

    0
    Comment actions Permalink
  • I dont think demanding and accusing is going to help them fix it faster. There's no reason to assume they are ignoring our plea to see our shows. It's probably a coding problem and their working to fix it but if they dont know what it is then imagine how much they need to check to find the problem. It's not like their just going to "turn it off and on again" and it's fixed. Give them a chance I'm sure we will all live until they fix it without staring at our tv's...

    However ....going into the menu and switching a few times through all of the languages un the acessibility option worked for me and I have subtitles back. 

    0
    Comment actions Permalink
  • Well done bob118.  That fix works for me and needs to be repeated for every episode watched.  Looking forward to a proper long-term fix now.

    3
    Comment actions Permalink
  • I think its poor service on Viki .Its to bad for people that are paying for this service I never had this problems with Dramafever, I also watch my Asian dramas on Netflix and Hulu and never had any problems. If you are going to have so many problems t you should drop your fees

    0
    Comment actions Permalink
  • Bob118

    Thanks It works.

    0
    Comment actions Permalink
  • It worked!!! Thank you!!

    0
    Comment actions Permalink
  • I am having the same issue and it started yesterday. I thought I did something wrong but it looks like it just isnt me

    1
    Comment actions Permalink
  • Hi, adding my issue. No subtitles on any show using roku

    0
    Comment actions Permalink
  • As bob118 stated the problem is with ultra roku with viki, but not with reg roku with viki. 

    0
    Comment actions Permalink
  • Same issue, no subs on any show using Roku. The fix above (switching languages) worked for a few episodes, but now I can’t even get that to work.

    FWIW - subs are fine on my phone and computer.

    1
    Comment actions Permalink
  • Having the same issue

    1
    Comment actions Permalink
  • I just wanted to add info. I am able to get English subtitles, but I have to ask for them. Instantly, on every episode. When I hit the asterisk option and go to settings for the individual episode, and go to “accessibility,” the “English” always has an asterisk in front of it, which is “when available.” If I use the arrow, I can move it to “English,” without the initial asterisk, and the subtitles appear. But it has to bd done again, for EVERY SINGLE EPISODE. That is the bug that needs to be fixed- so the setting keeps reverting automatically to *English instead of English.

    0
    Comment actions Permalink
  • I hope they fix this soon.  It's April 2nd at 7:00pm PST and still having issues.  The only way you might get substitles is when the program is on...press the * button and a screen may pop up asking you to make choices.  I have to keep pressing Always on and English Language...for whatever reason, it falls back into default of German Language.  It will work for a bit, but once a commercial comes on or it has a nano second pause...it goes back to no subtitles again.  

    0
    Comment actions Permalink
  • Thanks bob118😘

    0
    Comment actions Permalink
  • Okay I was panicking I uninstalled I reset my TV and I see that it’s an issue that’s being worked on okay thank you I’m glad I have my iPad or else I reallly be anxious lol

    0
    Comment actions Permalink
  • You are most welcome. Just remember to never give up. I have now watched 12 episodes, all with English subtitles. There were some that didn't load at first. I had to keep switching back and forth several times. At one point, I loaded German, then switched to English. My hope is that this discovery will help Viki understand where the issue lies and repair the actual cause. Until then, please continue to follow my suggested procedure.

    0
    Comment actions Permalink
  • Thanks Bob118! I see they may have solved it but I was able to watch with your solution!

    -1
    Comment actions Permalink
  • Bob118, thank you for your work-around!

    0
    Comment actions Permalink
  • @se_leigh

    I found your comment deeply offensive to the Viki community. Insulting the general Viki community and saying we just "stare" at our tv's -implying we don't have brains or take an active interest in the dramas and programs we watch is insulting. Please refrain from lashing out at the VIki community. Nobody here said or thought they just turn off and turn on Viki. A bit more info as to what was generally happening, a few more updates would have been welcome. Speaking down to us and acting as if you know better isn't really helpful here. I've rarely noticed anyone else doing that to people here.

    0
    Comment actions Permalink
  • And by the way, Viki themselves could have given us a work-around in the first place.

    0
    Comment actions Permalink
  • Subtitles now work w/out me having to do anything special. Tried four different shows (all Korean) and subtitles are now appearing normally. Roku Ultra, EN subtitles. Thanks, Viki. 

    0
    Comment actions Permalink
  • Thank you, Viki.  The subtitles work fine now.

    0
    Comment actions Permalink
  • Thanks very much for fixing the subs. :-)

     

    0
    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post