[Solved] Viki won't display videos, keeps kicking me back to Roku main page

Answered

Comments

13 comments

  • Official comment
    Avatar
    Kristie

    Hey guys,

    Sorry for the issues you were experiencing with the Roku app!

    We've just released a fix for the issue.

    To fix it, please take the following steps:

    1. Go to your Roku Settings > System System Update
    2. Click Check Now
    3. This will update your Viki Roku app to the latest version we just released that contains the fix to the issue

    Also, as there's multiple threads open for this issue, I've closed this thread. If you continue to experience issues, please update on the Viki on Roku not working thread.

    Cheers,
    Kristie

    Comment actions Permalink
  • Avatar
    irene921

    im getting that problem too

    0
    Comment actions Permalink
  • Avatar
    irene921

    actually i cant watch viki on my roku since last night, it says i have to subscribe to viki pass, but i am already a subscriber.

    0
    Comment actions Permalink
  • Avatar
    deadliftdiva_548

    Yup.  kicked me out twice.  Guess that's it for the roku app. @ kristie -it's raining bugs?

    0
    Comment actions Permalink
  • Avatar
    dezra

    Same here... click on an episode and it kicks you back to the roku menu. 😞

    0
    Comment actions Permalink
  • Avatar
    victoria63645_769

    Having the same problem. Posted about it, usually I hear from them immediately that they are looking into a problem I have but haven't heard from them yet.

    0
    Comment actions Permalink
  • Avatar
    mca4jock

    Me too!! Very annoying. And I’m on their Viki pass program also which increases the frustration level even higher.  Seems as though they have their “bug” fairly often with compensation for time lost in viewing.  

    0
    Comment actions Permalink
  • Avatar
    victoria63645_769

    https://support.viki.com/hc/en-us/articles/360000164208-Roku-App-Status-for-2018. I found this when I did a gooGoo search for the problem. They're building a new app.

    0
    Comment actions Permalink
  • Avatar
    heleng3

    I also have the Viki Pass.  I re-booted, logged out and in, entered codes, changed the batteries on the remote, etc. none of which helped. So I am frustrated, but in a way glad I'm not the only one with the same problem.  Hope this problem gets fixed quickly. Compensation?   Hmmm- how about giving us Viki Pass Plus..... : )

    1
    Comment actions Permalink
  • Avatar
    heleng3

    I also have the Viki Pass.  I re-booted, logged out and in, entered codes, changed the batteries on the remote, etc. none of which helped. So I am frustrated, but in a way glad I'm not the only one with the same problem.  Hope this problem gets fixed quickly. Compensation?   Hmmm- how about upgrading us Viki Pass Plus..... : )

    0
    Comment actions Permalink
  • Avatar
    heleng3

    I also have the Viki Pass.  I re-booted, logged out and in, entered codes, changed the batteries on the remote, etc. none of which helped. So I am frustrated, but in a way glad I'm not the only one with the same problem.  Hope this problem gets fixed quickly. Compensation?   Hmmm- how about upgrading us Viki Pass Plus..... : )

    0
    Comment actions Permalink
  • Avatar
    heleng3

    I also have the Viki Pass.  I re-booted, logged out and in, entered codes, changed the batteries on the remote, etc. none of which helped. So I am frustrated, but in a way glad I'm not the only one with the same problem.  Hope this problem gets fixed quickly. Compensation?   Hmmm- how about upgrading us Viki Pass Plus..... : )

    0
    Comment actions Permalink
  • Avatar
    msgmtj_134

    I have pass plus Kocowa level.  What you pay for makes no difference - you can view your viki page on roku, you can try to load an episode either through your history/watched list or through choosing a show in your watchlist/faves, loading "see all episodes" BUT when you choose an actual EPISODE and attempt to load it boots you back off the app.  Someone said they updated their app - hey, Viki, ever hear the maxim when it ain't broke, don't fix it?  Computer people think they have to keep "improving" their stuff but their improvements ALWAYS lead to more problems.  This happens at work every time the designers try and fix the problems in their program they designed  - once they fix a problem that existed, a bunch of other ones that were working just FINE before start giving error messages and/or stop working entirely.  Please please test run your 'improvements' moving forward before subjecting your PAYING CUSTOMERS to them!!!!

    0
    Comment actions Permalink

Post is closed for comments.