episodes not loading

Recently NONE of the episodes to newer shows will load. The past couple weeks when i try to watch True Beauty the episodes will not load on my chromebook, same goes for any other newer kdrama. I am able to watch the episodes on my phone but i really don't want to stare at my little screen for an hour to watch the show. I don't know why i can't watch on my chromebook anymore. I've updated the app and my chromebook. I try watching in browser too and they still won't load. Makes me very upset.



  • Official comment

    Hi there,

    Thanks for writing in to us.

    To grant permissions for DRM playback on Chromebook device, please follow these steps:

    1. On your Chromebook device, open Chrome.
    2. Select the three dots icon at the top right corner of your browser > Settings.
    3. At the bottom, select Advanced.
    4. In the "Privacy and security" section, select Site settings.
    5. Select Protected content.
    6. Turn on Allow identifiers for protected content.
      • To allow sharing on Viki, add it to the "Allow" list.

    You may also refer to this link for more details.

    Do let us know if the same issue persists after you've tried the above.

    Thank you,

    Comment actions Permalink
  • does anyone else have this problem ???

    Comment actions Permalink
  • Same here.  Also, one day I can download a video, .i.e Dr. Jin, The Great Doctor, the next day I couldn't.  I'm so frustrated with Viki that I'm going to cancel my subscription.

    Comment actions Permalink
  • squiggles_2 i finally got mine to work. If you go to the viki website and click the little black lock by the website name then click site settings then click rest permissions and then get off it and go back to the viki website it should ask you to allow (i forgot what it said) so click allow and then it should work !!! That's exactly what i did and it worked :) sorry if my instructions are not clear 

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post