[Closed] Subtitles on Roku not updated

Within the app the subtitles work as well as on other devices. The subtitles work for episodes that are a few days old, but not new episodes. It should have what each episode is updated to. I’m trying to watch Boys Planet new episode which is 100% subbed but on the Roku no subtitles are showing up. I refreshed the app and uninstalled .. etc.


  • Official comment

    Hi everyone,

    ryoato, thanks for sharing some workaround. We appreciate you raising this subtitle concern with Viki on Roku. 

    We're aware of this issue on Viki and we apologize for the inconvenience this has caused you. 

    Do follow this post for more information/updates as this duplicate topic would be closed.

    We appreciate your patience and understanding in this matter.


    Comment actions Permalink
  • I have the same issue.  I tried restarting the Roku, then deleting the app and reinstalling it, but it's the same with all the newly added episodes.

    Comment actions Permalink
  • I am having the same issue. Home Alone, Boys Planet and Vengeance of the Bride. I have tried all the normal steps to correct it. Works just fine on my iPhone.

    Comment actions Permalink
  • I had someone able to help me and this is the steps to follow :

    1. Go to video
    2. Once it starts press the * on your remote
    3. The pop up menu appears
    4. Go to accessibility and captions
    5. Go to caption track and pick the 2nd English option
    6. Close the pop up menu and press play

    I found if it isn’t working right away after that go back to the menu and then press pause and play and it should work.

    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post