[Solved] Chromecast subtitles don't work

I'm not sure if this is my problem or yours.  It appears you addressed this issue in 2018 but I cannot find anything more recent.  They were working perfectly until yesterday when I stopped getting subtitles on either TV when casting from your site.  If you have already addressed this issue, would you please point me to a link where I can get info to fix this.  Thank you very much.

Kristin Redpath




  • Official comment

    Hi both,

    This subtitle issue should be fixed so do try to cast your shows again. 

    If you are still having technical issues, please send details (screenshots included) to our Help Center at and we will get back to you as soon as possible.

    Thank you,

    Comment actions Permalink
  • Same thing for me. Worked fine last night and today it isn't working while streaming to chromecast. Subtitles are fine on OS11

    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post