[Solved] Subtitles on chromecast

I suddenly have no subtitles when I cast from iOS to tv. It works fine on other apps. I can see it on iOS alone. Have reinstalled app. No luck. I see you solved the issue in the past but it seems to be recurring.


  • Official comment

    Hi Everyone,

    This subtitle issue is now fixed so you may resume watching per usual. :) 

    If you are still having technical issues, please send details (screenshots included) to our Help Center at and we will get back to you as soon as possible.

    Thank you for your patience. 



    Comment actions Permalink
  • I am experiencing the same! 6:25 mountain time USA. Hope it can be fixed soon. Fingers crossed!

    Comment actions Permalink
  • 9:30 pm Eastern ST Canada. No subtitles when using Chromecast from iOS to my TV.

    Comment actions Permalink
  • Hi All,

    Thank you for reaching out!

    We're aware of the subtitle issue on Chromecast. 

    In the meantime, we suggest watching on or on other supported devices.

    Sorry for the inconvenience and thank you for your patience as we work on fixing this!

    We will post updates here once the issue is resolved. You can refer to our Twitter page @VikiStatus for more immediate support updates in the future. You can also access this page without owning a Twitter account.

    Thank you,

    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post