Ceased Support for Viki app versions older than 2.5.0 on Android TV and Fire TV

We’ll be ending support for Viki app versions older than 2.5.0 on Android TV and Fire TV on Feb 5th, 2021. Users will be prompted to upgrade their apps starting from Jan 12th, 2021.

What if I’m not able to download (or update to) the latest version of the app?

If you’re facing issues downloading the latest version, please try these steps below:

  • Ensure that your streaming/TV device has sufficient memory/storage space
  • Make sure your OS is updated to the latest version
  • Manually uninstall the current app version and reinstall the latest version from the app store

If you’re still unable to download the latest version of the app, it is most likely because your device has an Operating System (OS) version of Android that’s incompatible with Viki. 

Learn how to install or update your Viki app on Android TV or Fire TV here.


What if I’m still having issues downloading?

If your device is incompatible with the Viki app on Android/Fire TV, you can continue watching Viki from other compatible devices and from our website. You can see all of our supported apps here: Viki.com/apps

Was this article helpful?
11 out of 19 found this helpful

Comments

1 comment

Please sign in to leave a comment.