Supported Devices

Supported Devices

  • Android phones, tablets, and Chromebooks (Android OS 6.0 and above) 
  • iPhones and iPads (iOS 14.0 and above)
  • Android TV (Android OS 6.0 and above)
  • Google TV (Android OS 6.0 and above)
  • Apple TV HD (4th generation) and newer (tvOS 14 and above)
  • AirPlay (iOS devices to Apple TV only)
  • Amazon Fire TV (Fire OS 6.0 and above)
  • Roku (Roku OS 9 and above) 
  • Chromecast (Only with a Viki Pass subscription) 

We're no longer supporting the following apps and devices on Viki:

  • Xbox 360
  • Nook
  • Windows Phone
  • Nokia
  • Blackberry
  • Firefox OS
  • Samsung Smart TV
  • Amazon Kindle Fire
  • Telstra-Roku TV 
  • Smart TV web browsers
  • Playback via HDMI cable
  • Screen Mirroring

You can find all our supported apps and additional information here: Viki.com/apps

Important: Rooted and jailbroken devices are not supported.

You can learn how to update your device software here.

Important: If your device is incompatible with the latest Viki app versions, you can continue to watch Viki using your current app. However, you will no longer receive new app updates.
Was this article helpful?
889 out of 1445 found this helpful

Comments

0 comments

Article is closed for comments.