Question

6 Followers
7
Avatar

It Freeze..!

Hi..

I've been having this problem for a while. whenever I watch dramas here, the videos just freeze for some reason and I have no clue why this happens, whether it's on high resolution or not. Sometimes I play the drama episodes back-to-back, do you think this might be the reason? the only way I can watch the video again is by refreshing the page and look where I had stopped.

Please help!

shkhayyat

Please sign in to add your answer.

6 answers

0
Avatar

I have the same problem. Help center people just said it was my network and gave me something to download to check> ididn't download anything because I don't think it is it, since crunchyroll, hulu, netflix, youtube, and all the other ones totally never freeze. Only viki. Which totally sucks. It does it on chrome, firefox, internet explorer.  If you ever find an answer let me know because it's driving me crazy.

kikilouie
0
Avatar

I'm having the same problem, it's really annoying! It started some months ago, in every video I try to watch. I tried all the browsers and it always happens, but I have a good network and videos in other sites work perfectly. I hope this problem can be fixed somehow. D: 

kafields
0
Avatar

I've been having the same problem, please let me know if there is a fix for this, i run Google Chrome and keep my computer up to date with both software and hardware.

alvin_pham
0
Avatar

Okay, after doing some tinkering and research, I came to the conclusion that it was my browser and firewall creating the problem. What i found was that whenever the video stopped it was trying to play an advertisement but my popup blocker was preventing it from loading. There are two ways that i worked around this issue, one was to disable my popup blocker when i watched videos on viki, and the other was to install a third party popup blocker as a plugin into google chrome, like Ad Blocker Plus, but beware it will remove all adverts and popups so viki will no longer receive revenue from their advertisements, and some site will require you to disable it. Hope this helps

alvin_pham